ぴぴぶろぐ

いろいろたまにプログラミング

Discord botが動いていませんでした。

ぴぴです。

最近忙しくてBot関係から遠ざかってたのですが、久々にブキルーレットBotの状況を見に行ったら

TypeError: __new__() got an unexpected keyword argument 'deny_new'

 というエラーを吐いていて動いていませんでした。多分一週間ほど動いてませんでした。サーバーに導入してくださった方には申し訳ありませんでした。

 

ちなみに、herokuで実行していたのですが、原因はrequirements.txtに記載してあるdiscord.pyのバージョンが1.0.0aだったから、という理由でした。

 

 このツイートを見て、「これ自分のBotも止まってるいるのではないか」と思って確認したら動いてませんでした。requirements.txtにdiscord.pyのバージョンを書いたことは覚えていたので1.0.0aを1.3.4に書き換えたら動くようになりました。

 

これからは更新情報なども収集しなければいけないなぁ、と思いました。(小並感)